make a donation to the fz1oa
fz1oa chat
fz1oa picture uploader
maintain your own photo albums
locate fz1oa members
search the entire board
click here for fz1oa web site home page
register a new account, it's free!
email the fz1oa webmasters
read the fz1oa guidelines
read the fz1oa policy
open pat's fz1 site in a new window
open iowaz fz1 site in a new window
technical tips

Go Back   FZ1OA Message Board > FZ1 & Fazer Owners Association > FZ1 Problems & Issues > Gen 2 Problems & Issues

Reply
 
Thread Tools Display Modes
Old 03-25-2010, 05:03 PM   #1
jredford
Musical Metal
 
jredford's Avatar
 
Join Date: Aug 2009
Location: Houston
Posts: 15,014
Diagnostic Codes

Copied this from another site...Codes for Gen II with explanation.


Next time it acts up, get it into diagnostics mode.

1) Turn key to off
2) Turn ignition kill switch to run
3) Hold the select and reset button at the same time
4) Turn the key to run
5) Continue to hold the two buttons and count to about 10 at this point the display will show "d1"
6) Release the two buttons
7) Repress both buttons for 2 sec and the display will show d:01_____17

The 17 that I get, can be anything from 15-18. This is the throttle position reading. As you S L O W L Y roll on the throttle, the number on the dash has to roll smoothly up to between 95 and 100 at WOT

If you get any jumping or holes in the numbers the TPS is the issue and must be repaired.

Here is all of the codes that I have found as you scan thru them.

01 - Throttle position sensor signal
02 - Atmospheric pressure Displays the atmospheric
03 - Intake air pressure Displays the cylinder-#1
05 - Intake air temperature Displays the intake air temperature.
06 - Coolant temperature Displays the coolant temperature.
07 - Vehicle speed pulse 0–999 Check that the number
08 - Lean angle sensor Remove the lean angle
09 - Fuel system voltage
20 - Sidestand switch Set ON/OFF the sidestand
21 - Neutral switch Set ON/OFF the neutral
30 - Cylinder-#1 ignition coil Actuates the cylinder-#1 ignition
31 - Cylinder-#2 ignition coil Actuates the cylinder-#2 ignition
32 - Cylinder-#3 ignition coil Actuates the cylinder-#3 ignition
33 - Cylinder-#4 ignition coil Actuates the cylinder-#4 ignition
36 - Injector #1 Actuates the injector #1 five
37 - Injector #2 Actuates the injector #2 five
38 - Injector #3 Actuates the injector #3 five
39 - Injector #4 Actuates the injector #4 five
48 - Air induction system solenoid
50 - Fuel injection system relay Actuates the fuel injection
51 - Radiator fan motor relay Actuates the radiator fan
52 - Headlight relay Actuates the headlight relay
53 - Exup servo motor Actuate the servo motor turns
56 - Sub-throttle servo motor Actuate the servo motor turns
60 - EEPROM fault cylinder No
61 - Malfunction history code
62 - Malfunction history code
63 - Malfunction code reinstate

And here are the ECU error codes

11 - Cylinder identification sensor
12 - Crankshaft position sensor
13 - Intake air pressure sensor
14 - Intake air pressure sensor hose line
15 - Throttle position sensor (open or short circuit)
16 - Throttle position sensor (stuck)
17 - EXUP servo motor potention circuit
18 - EXUP servo motor (stuck)
19 - Sidestand switch (open circuit in the
20 - Intake air pressure sensor or atmospheric
21 - Coolant temperature sensor
22 - Intake air temperature sensor
23 - Atmospheric pressure sensor
24 - O2 sensor No normal signal is received from the O2 sensor.
30 - Lean angle sensor (latch up detected)
33 - Cylinder-#1 ignition coil
34 - Cylinder-#2 ignition coil
35 - Cylinder-#3 ignition coil
36 - Cylinder-#4 ignition coil
39 - Injector (open circuit)
41 - Lean angle sensor (open or short-circuit)
42 - Speed sensor No normal signals are received from the speed sensor.
43 - Fuel system voltage (monitoring voltage)
44 - Error in writing the amount of CO adjustment
46 - Vehicle system power supply
47 - Sub-throttle servo motor potention (open
48 - Monitor the operation of the sensors and
48 - Sub-throttle servo motor (lock)
50 - ECU internal malfunction (memory check error)

Hope this helps

AW
__________________




2013 Ninja 300 Race Bike
2016 KTM 1290 Super Adventure
jredford is offline   Reply With Quote
Old 03-25-2010, 10:18 PM   #2
liquidfizz
Registered User
 
Join Date: Aug 2006
Location: Marysville, PA
Posts: 186
Thanks, printed it out and putting it in my owners manual under my seat.
liquidfizz is offline   Reply With Quote
Old 03-26-2010, 03:22 AM   #3
hotcam
Registered User
 
hotcam's Avatar
 
Join Date: Jan 2008
Location: Down Under, Australia
Posts: 648
Looks great, thanks! Hopefully I never need to look them up though...
__________________
"And they had a machine, a dream of a machine, with wheels and gears and perfect in every respect; and they lived on it" - Lem, 'Cyberiad'

FZR1040 Track: Racetech/Ohlins susp, Brembo/ Bluspot/HEL/radial brakes, forged pistons, compressed 12.7:1, Burgess head, Hallam block, Moriwaki 4-1, FP Carbs, MSD MC3+ Ignition, K+N.

FZ-1S sleeper:Full fairing, tall screen, hard bags, Airbox mod+BMC, FPro Velocity Stacks, PC3+Ign Mod (Duke map), Cut Short Yoshi TRC 4-2-1, Barnett clutch, SpeedoHealer.
hotcam is offline   Reply With Quote
Old 07-07-2010, 06:09 AM   #4
yamihoo
Registered User
 
yamihoo's Avatar
 
Join Date: May 2009
Location: Minneapolis MN
Posts: 158
Will the engine light come on any time you have a fault code present?
__________________
Naked 07'Cobalt PCIII~2Bros VALE CF S/O~GuttedCat~ExupElim~K&N~AirBoxMod~Integrated Tail.....and a bunch other goodies

Last edited by yamihoo; 07-09-2010 at 09:03 AM.
yamihoo is offline   Reply With Quote
Old 11-09-2010, 10:39 AM   #5
BuddyWJ
Buddsterboy
 
BuddyWJ's Avatar
 
Join Date: Sep 2005
Location: Midland,MI
Posts: 73
One step listed in the service manual when running diagnostic codes that is not listed here is to "Disconnect the wire harness coupler from the fuel pump."

Can this step be skipped and not cause harm and still get correct readings?
BuddyWJ is offline   Reply With Quote
Old 11-09-2010, 11:00 AM   #6
jredford
Musical Metal
 
jredford's Avatar
 
Join Date: Aug 2009
Location: Houston
Posts: 15,014
I have a Gen II and have never heard of that.
__________________




2013 Ninja 300 Race Bike
2016 KTM 1290 Super Adventure
jredford is offline   Reply With Quote
Old 11-09-2010, 11:49 AM   #7
TheRepairMan
2006 to 2017 & SOLD!
 
TheRepairMan's Avatar
 
Join Date: Nov 2005
Location: Bluff City, Tennessee
Posts: 4,094
Quote:
Originally Posted by BuddyWJ View Post
One step listed in the service manual when running diagnostic codes that is not listed here is to "Disconnect the wire harness coupler from the fuel pump."

Can this step be skipped and not cause harm and still get correct readings?
Quote:
Originally Posted by jredford View Post
I have a Gen II and have never heard of that.
You don't unhook anything just to pull up codes. Now if you start enabling actuators, such as fuel injectors, etc., that's a different matter.

-Roger
__________________


Dielectric grease information, IMPORTANT! http://www.yamahafz1oa.com/forum/sho...3&postcount=42

Ignition coil information, FYI. http://www.yamahafz1oa.com/forum/sho...0&postcount=26
TheRepairMan is offline   Reply With Quote
Old 12-02-2010, 10:36 PM   #8
Oshiat
Registered User
 
Join Date: May 2008
Posts: 57
Can any of you guys tell me how to reset the errors? I dont have the service manual yet. Thx
Oshiat is offline   Reply With Quote
Old 12-02-2010, 11:39 PM   #9
Blind Spot
Represent
 
Blind Spot's Avatar
 
Join Date: Nov 2008
Location: San Diego, CA - USA
Posts: 9,207
Quote:
Originally Posted by Oshiat View Post
Can any of you guys tell me how to reset the errors? I dont have the service manual yet. Thx
Fix the problem. They reset themselves.
__________________
Super Kinky Fuel Line Mod - Unkink your Fuel pipe on the cheap.

http://yamahafz1oa.com/forum/showthread.php?t=105290

Businesses love a working server, don't trust India, see an IT admin and get rid of it.
Blind Spot is offline   Reply With Quote
Old 02-01-2011, 05:47 PM   #10
Ramenx
Driver
 
Ramenx's Avatar
 
Join Date: Aug 2010
Location: Pensacola, Fl
Posts: 75
I vote to make this a sticky, very good post and would cut down on code posting..
Ramenx is offline   Reply With Quote
Old 04-02-2011, 02:57 PM   #11
max power
Registered Boozer
 
max power's Avatar
 
Join Date: May 2010
Location: Central Ahia
Posts: 151
Quote:
Originally Posted by liquidfizz View Post
Thanks, printed it out and putting it in my owners manual under my seat.
+1 Thanks!
__________________
Creature of Habit
3 Yammies-06 FZ1, 01 Warrior, 03 Wolverine
2 Yotas
& a Big Ass Burb
max power is offline   Reply With Quote
Old 10-22-2011, 07:10 PM   #12
benc2022
whatsacar?
 
benc2022's Avatar
 
Join Date: Aug 2011
Location: Phoenix
Posts: 178
Quote:
Originally Posted by jredford View Post
Copied this from another site...Codes for Gen II with explanation.


Next time it acts up, get it into diagnostics mode.

1) Turn key to off
2) Turn ignition kill switch to run
3) Hold the select and reset button at the same time
4) Turn the key to run
5) Continue to hold the two buttons and count to about 10 at this point the display will show "d1"
6) Release the two buttons
7) Repress both buttons for 2 sec and the display will show d:01_____17

The 17 that I get, can be anything from 15-18. This is the throttle position reading. As you S L O W L Y roll on the throttle, the number on the dash has to roll smoothly up to between 95 and 100 at WOT

If you get any jumping or holes in the numbers the TPS is the issue and must be repaired.

Here is all of the codes that I have found as you scan thru them.

01 - Throttle position sensor signal
02 - Atmospheric pressure Displays the atmospheric
03 - Intake air pressure Displays the cylinder-#1
05 - Intake air temperature Displays the intake air temperature.
06 - Coolant temperature Displays the coolant temperature.
07 - Vehicle speed pulse 0–999 Check that the number
08 - Lean angle sensor Remove the lean angle
09 - Fuel system voltage
20 - Sidestand switch Set ON/OFF the sidestand
21 - Neutral switch Set ON/OFF the neutral
30 - Cylinder-#1 ignition coil Actuates the cylinder-#1 ignition
31 - Cylinder-#2 ignition coil Actuates the cylinder-#2 ignition
32 - Cylinder-#3 ignition coil Actuates the cylinder-#3 ignition
33 - Cylinder-#4 ignition coil Actuates the cylinder-#4 ignition
36 - Injector #1 Actuates the injector #1 five
37 - Injector #2 Actuates the injector #2 five
38 - Injector #3 Actuates the injector #3 five
39 - Injector #4 Actuates the injector #4 five
48 - Air induction system solenoid
50 - Fuel injection system relay Actuates the fuel injection
51 - Radiator fan motor relay Actuates the radiator fan
52 - Headlight relay Actuates the headlight relay
53 - Exup servo motor Actuate the servo motor turns
56 - Sub-throttle servo motor Actuate the servo motor turns
60 - EEPROM fault cylinder No
61 - Malfunction history code
62 - Malfunction history code
63 - Malfunction code reinstate

And here are the ECU error codes

11 - Cylinder identification sensor
12 - Crankshaft position sensor
13 - Intake air pressure sensor
14 - Intake air pressure sensor hose line
15 - Throttle position sensor (open or short circuit)
16 - Throttle position sensor (stuck)
17 - EXUP servo motor potention circuit
18 - EXUP servo motor (stuck)
19 - Sidestand switch (open circuit in the
20 - Intake air pressure sensor or atmospheric
21 - Coolant temperature sensor
22 - Intake air temperature sensor
23 - Atmospheric pressure sensor
24 - O2 sensor No normal signal is received from the O2 sensor.
30 - Lean angle sensor (latch up detected)
33 - Cylinder-#1 ignition coil
34 - Cylinder-#2 ignition coil
35 - Cylinder-#3 ignition coil
36 - Cylinder-#4 ignition coil
39 - Injector (open circuit)
41 - Lean angle sensor (open or short-circuit)
42 - Speed sensor No normal signals are received from the speed sensor.
43 - Fuel system voltage (monitoring voltage)
44 - Error in writing the amount of CO adjustment
46 - Vehicle system power supply
47 - Sub-throttle servo motor potention (open
48 - Monitor the operation of the sensors and
48 - Sub-throttle servo motor (lock)
50 - ECU internal malfunction (memory check error)

Hope this helps

AW
you're awesome. Thanks
benc2022 is offline   Reply With Quote
Old 10-22-2011, 07:50 PM   #13
jredford
Musical Metal
 
jredford's Avatar
 
Join Date: Aug 2009
Location: Houston
Posts: 15,014
You're welcome!
__________________




2013 Ninja 300 Race Bike
2016 KTM 1290 Super Adventure
jredford is offline   Reply With Quote
Old 08-03-2012, 04:20 AM   #14
RosettaStonedVA
Registered User
 
Join Date: Jun 2012
Posts: 7
Just the other day Im getting an error code 16. (throttle position sensor stuck). When I roll on the throttle it goes through each number without skipping any and ends at 96 every time. The engine warning light is intermittent but it worries me when it wont go off. It comes ON more often than not now.
RosettaStonedVA is offline   Reply With Quote
Old 09-30-2012, 12:34 PM   #15
terdog
RIDE OR DIE
 
terdog's Avatar
 
Join Date: May 2008
Location: Garderville, NV
Posts: 2,389
I have the same issue. Can it be adjusted?
terdog is offline   Reply With Quote
Old 01-26-2013, 05:44 PM   #16
T0T4LBL4CK0UT
Registered User
 
Join Date: Jan 2013
Posts: 16
I guess I don't understand how to tell if you have a code being issued. I've got through it a few times and the servo motor actuated and such thinks but I never noticed anything that said this is acting up
T0T4LBL4CK0UT is offline   Reply With Quote
Old 01-26-2013, 07:05 PM   #17
AndyW
Dumbass with a full PM inbox..
 
AndyW's Avatar
 
Join Date: May 2010
Location: Marietta, GA
Posts: 23,859
The check engine light comes on if you have an error code, and the code itself shows up in place of the odo.
..a
__________________
'01 FZ1 set up for distance
'07 FZ1 set up for fun
(both in the *faster* blue)


Which would you prefer?
AndyW is offline   Reply With Quote
Old 06-24-2014, 09:09 AM   #18
wildwhl
Registered User
 
Join Date: Apr 2014
Posts: 30
Maybe I'm being dense here - but how do you know the difference between the first list of codes and the *ECU* error codes when checking the display?

EDIT: Nevermind - wasn't awake when I typed this and I get it now.

WW

Last edited by wildwhl; 06-25-2014 at 10:44 AM.
wildwhl is offline   Reply With Quote
Old 08-29-2015, 01:09 AM   #19
danjuma
Danjuma
 
Join Date: Apr 2015
Posts: 1
hi guys I ride every day to and almost anywhere on bike I have a gen 2 with 48,000km on the odo I went on a trip for a week and came back turn on the ignition and I didn't get the normal cycle u normally get when turn on the key all I got was the whole screen was blank except for the fuel indicator that was blinking so I start the bike and it starts rpm works normal but the screen still black I started riding then just before the 3rd gear it all rest like it does when you turn on the key it works fine it happens all the time now each time I want start the bike regardless of the bikes temperature so what could be the problem any help pls.
danjuma is offline   Reply With Quote
Old 03-25-2017, 03:11 PM   #20
brynmor1
Brynmor1
 
Join Date: Sep 2016
Location: Aberystwyth
Posts: 4
Hi. I had to put a new battery on my bike and know the engine management light is on. How do i turn it off.. thks
brynmor1 is offline   Reply With Quote
Reply

Go Back   FZ1OA Message Board > FZ1 & Fazer Owners Association > FZ1 Problems & Issues > Gen 2 Problems & Issues


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -7. The time now is 09:53 AM.


Questions? Comments?
Click on name below to contact via PM
Rabeet (Admin) Desmo (Admin)

Powered by vBulletin® Version 3.7.4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Website and Message Board Contents Copyright 2001-2007 FZ1OA
The marks YAMAHA® and FZ1® are used under license from Yamaha Motor Corporation, U.S.A.
The information on this web site is NOT approved or endorsed by Yamaha Motor Corporation in any way.
Page generated in 0.12727 seconds with 8 queries