View Single Post
Old 04-05-2018, 07:40 PM   #702
Cruzman
ATGATT It's the only way 2 fly
 
Cruzman's Avatar
 
Join Date: Sep 2009
Location: Hiram, GA
Posts: 3,028
This week I took Trixi to the BMW dealer because I had the light associated to the lean angle sensor / accelerometer stay lit on startup which means that there is a fault. The dealer charged me for a half hour of labor to diagnose it. They came back with its either the sensor going bad and will need to be replaced to the tune of about $700 or the wires that I have added for the extra lights, battery tender, and heated gear cord is vibrating up against it causing it to loose its mind. They reset the computer (turned off the light) and suggested I tidy up my wiring to see if that fixes the problem.

This has all now been done.

During my haste to take me bike to the dealer (on my bike carrier that attaches to the back of the truck), I forgot and left my Bag Connection brackets sitting on the back of the truck and took them for a ride down the road never to be seen again. I e-mailed SW-MOTECH regarding purchasing replacements. They responded by connecting me to Twisted Throttle here state side, who stated they would have the parts in, in about 4 or 5 weeks as they were special order from SW-MOTECH. I responded bask dreading the price quote since they did not include the $ in their reply. Their response to my query was "We have requested these parts be replaced under warranty so there will be no charge for them"! Please send some business to Twisted Throttle as it is obvious they look out for their customers.
__________________
Cruzman
Atlanta, GA

2001 FZ1000 "Stella" Re-jeted, AIS eliminated, 07 R1 Fork Swap with BrianG stem and AK20s, mini led turn signals, K&N filter, R6 rear shock conversion,Gauge of Eternal Coolness, 4 degree advancer mod, SS Brake-Lines
DanMoto Rearsets, Akrapovic slip-on [/color]
2014 BMW S1000R "Trixie"
Cruzman is offline   Reply With Quote
 
Page generated in 0.06282 seconds with 8 queries